Remote Mikrotik v5.20 Webfig Dari Luar Jaringan

Webfig Mikrotik Versi 5.20 sudah cukup userfriendly pada tampilan desktopnya, jadi untuk remote srver mikrotik bisa menggunakan browser.

Sebelumnya kita tentukan terlebih dahulu ip modem dam ip mikrotik secara manual :

1. 192.168.90.1 —–> ip modem menuju mikrotik

2. 192.168.90.2 —–> ip mikrotik menuju modem

Kemudian kita lakukan setting pada mode dan mikrotik :

1. Buka port yang akan kita remote pada modem, webconfig menggunakan port 80 untuk remote, tapi agar tidak ketuker sama browsing saya manggunakan port 90 yang nantinya akan dialihkan pada port 80 melalui pengaturan di mikrotiknya.

2. Buat NAT untuk mengalihkan port yang kita remote agar masuk ke port 80 di mikrotik, dengan script sebagai berikut :

ip firewall nat

add action=dst-nat chain=dstnat protocol=tcp dst-port=90 t0-address=192.168.90.2 to-port=80 comment=”mikrotik-web-config”

Settingan selesai, sekarang kita coba buka browser di jaringan luar dengan mengetikkan ip publik kita dengan port 90 yang telah kita tentukan tadi :

http://119.68.56.125:90

maka akan muncul webfig seperti pada gambar berikut :

webfig

selamat… anda berhasil remote server mikrotik anda melalui browser dari luar jaringan…

Agar Mikrotik Tidak Open Proxy

Judulnya keren hehehe… konsep ini sebenarnya sangat simple, namun sangat bermanfaat bagi pengguna proxy di mikrotik. Secara tidak disadari ketika kita mengaktifkan fitur web proxy di mikrotik, ip publik kita  terbuka di dunia maya yang terdeteksi adanya proxy, sehingga server proxy kita bisa digunakan oleh orang lain, alhasil internet lokal kita jadi lambat karena proxy kita banyak yang pakai dari luar. Script berikut adalah jurus ampuh agar server mikrotik kita tisak open proxy. Silakan disimak dan dipakai… hehehe

/ip firewall filter
add chain=input in-interface=modem protocol=tcp dst-port=8080 connection-state=new action=drop

Modem pada interface=modem adalah port mikrotik menuju modem dan dst-port=8080 adalah port yang kita gunakan sebagai proxy, silakan sesuaikan dengan setingan di jaringan anda. Semoga bermanfaat.

Limit Torrent di Mikrotik

September 26, 2012 5 komentar

Berawal dari dari adanya client hotspot yang hobby download film menggunakan torrent. Repotnya walau bandwidth sudah dibatasi di user hotspot tapi dengan torrent bisa tembus hingga bandwidth di DRNet bisa terkuras habis oleh satu client. Rugi dong client yang laen pada teriak… akhirnya begadang semaleman muter otak cari konsep limit bandwidth yang bisa membatasi torrent. Akhirnya ketemu deh caranya.. dan tutorial berikut gabungan dari artikel blokir torrent dan membatasi bandwith iix dan intl serta queue tree membatasi bandwith client sama rata. Ok simak saja langsung scripnya, semoga bermanfaat.

A.    Membuat Layer 7 Protocol untuk menangkap Torrent
/ip firewall layer7-protocol

add name=bittorrent regexp=”^(\13bittorrent protocol|azver1\$|get /scrape\\\?info_hash=)|d1:ad2:id20:|8’7P\\)[RP]“

add name=torrent-wws regexp=”^.*(get|GET).+(torrent|info_hash|thepiratebay|isohunt|entertane|demonoid|btjunkie|mininova|flixflux|vertor|h33t|zoozle|bitnova|bitsoup|meganova|fulldls|btbot|fenopy|gpirate|commonbits).*\$”

add name=torrent-www regexp=\”^.+(torrent|thepiratebay|isohunt|entertane|demonoid|btjunkie|mininova|flixflux|vertor|h33t|zoozle|bitnova|bitsoup|meganova|fulldls|btbot|fenopy|gpirate|commonbits).*\$”

B.     Membuat Mangle

/ip firewall mangle

add action=mark-connection chain=forward layer7-protocol=bittorent new-connection-mark=bittorent-limit passthrough=yes comment=”bittorent”

add action=mark-packet chain=forward connection-mark=bittorent-limit new-packet-mark=packet-bittorent passthrough=no

add action=mark-connection chain=forward layer7-protocol=torrent-wws new-connection-mark=wws-limit passthrough=yes comment=”torrent wws”

add action=mark-packet chain=forward connection-mark=wws-limit new-packet-mark=packet-wws passthrough=no

add action=mark-connection chain=forward layer7-protocol=torrent-www new-connection-mark=www-limit passthrough=yes comment=”torrent www”

add action=mark-packet chain=forward connection-mark=www-limit new-packet-mark=packet-www passthrough=no

add action=mark-connection chain=forward p2p=all-p2p new-connection-mark=allp2p-limit passthrough=yes comment=”torrent allp2p”

add action=mark-packet chain=forward connection-mark= allp2p-limit new-packet-mark=packet-allp2p passthrough=no

add action=mark-connection chain=forward protocol=tcp src-port= 58561,58045,14948,58008,58816,59097 new-connection-mark=port-limit passthrough=yes comment=”torrent port”

add action=mark-packet chain=forward connection-mark= port-limit new-packet-mark=packet-port passthrough=no

C.    Membuat Queue Type

/queue type
add kind=pcq name=torrent pcq-classifier=dst-address pcq-limit=50 pcq-rate=128k pcq-total-limit=2000

D.    Membuat Queue Tree

/queue tree
add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=0
max-limit=256kname=bittorrent packet-mark=packet-bittorent parent=global-out priority=8 queue=torrent comment=”limit torrent”

add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=0
max-limit=256kname=wws packet-mark=packet-wws parent=global-out priority=8 queue=torrent

add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=0
max-limit=256kname=www packet-mark=packet-www parent=global-out priority=8 queue=torrent

add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=0
max-limit=256kname=port packet-mark=packet-port parent=global-out priority=8 queue=torrent

add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=0
max-limit=256kname=allp2p packet-mark=packet-allp2p parent=global-out priority=8 queue=torrent

begitu saja sudah cukup, client yang pake torrent akhirnya bisa dibatasi dengan bandwidth di queue tree yang kita tentukan. Keep ngoprek.. ^_^

Cara join file split di ubuntu

Salah satu file split adalah ketika kita download file film yang terpisah-pisah, maka file tersebut harus kita satukan agar bisa menjadi file movie.

Kalau di windows kita biasanya menggunakan aplikasi hjsplit untuk menyatukan file-file tersebut, tapi di ubuntu tidak memerlukan aplikasi tambahanseperti di windows.

Dengan menggunakan perintah cat kita sudahbisa menyatukan file split di ubuntu seperti contoh berikut :

film.mkv.001
film.mkv.002
film.mkv.003
film.mkv.004

file-file tersebut tersimpan di folder /home/zen/Downloads.

maka langkah pertama : buka terminal
kemudian ketik cd /home/zen/Downloads << masuk pada folder yang ada file-file tersebut. kemudian ketik seperti ini :

Zen@Toshiba:~$ cat film.mkv.001 film.mkv.002 film.mkv.003 film.mkv.004 > film.mkv
kemudian tekan ENTER. 
pisahkan setiap nama file dengan spasi

atau bisa juga dengan perintah :
Zen@Toshiba:~$ cat film.mkv.00* > film.mkv

Maka file split kita sudah selesai dijoin. semoga bermanfaat

Install JDownloader di Ubuntu 11.10

Cara Install JDownloader

Buka Terminal dan ketik perintah berikut

sudo add-apt-repository ppa:jd-team/jdownloader

sudo apt-get update

sudo apt-get install jdownloader

koneksikan pc ubuntu anda dengan internet, kemudian buka jdownloader, biarkan update sampai selesai

 

Cara Intergrasi dengan Firefox

Buka firefox anda dan pilih menu add-ons

cari FlashGot dan Install

Setelah selesai Install FlashGot klik pada tombol properties, pilih JDownloader kemudian OK

makan JDownloader anada sudah terintegrasi dengan Firefox.

Semoga bermanfaat.

 

Mengubah Permission di Mount /media Ubuntu

 

Ketik Perintah ls -l /media seperti berikut :

zen@Toshiba:~$ ls -l /media

total 4

drwxr-xr-x 3 root root 4096 2012-04-20 19:49 Data

 

Perhatikan Mount Point/ Partisi Data disini hanya dapat diakses oleh root.

Maka kita harus menambah permision sebagai user zen dengan perintah sebagai berikut :

 

zen@Toshiba:~$ sudo chown -R zen /media/Data

[sudo] password for zen:

 

Kemudian cek kembali dengan perintah la -l /media seperti berikut :

 

zen@Toshiba:~$ ls -l /media

total 4

drwxr-xr-x 3 zen root 4096 2012-04-20 19:49 Data

 

Maka akan tampil user zen seperti di atas, artinya dapat mengakses di Mount point/ partisi Data.

Coba copy file pada folder lain dan paste di Mount point Data tersebut, harus sudah bisa.

Semoga bermanfaat.

 

Cara Setting Modem Venus Fast 2 di Ubuntu 11.10

Koneksikan modem Venus Fast 2 kita ke port usb yang tersedia.

Buka Terminal Ubuntu dan ketik perintah lsusb seperti berikut :

$ lsusb

Kemudian akan munsul seperti tampilan berikut :

Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 003 Device 002: ID 0a12:0001 Cambridge Silicon Radio, Ltd Bluetooth Dongle (HCI mode)
Bus 005 Device 007: ID
05c6:1000 Qualcomm, Inc. Mass Storage Device

Perhatikan yang dicetak tebal, dari sini kita ketahui bahwa ID modem kita 05c6:1000

Mengedit file /lib/udev/rules.d/40-usb_modeswitch.rules dengan perintah :

$ sudo nano /lib/udev/rules.d/40-usb_modeswitch.rules

Cari scrip yang bertuliskan Prolink dengan menekan tombol Ctrl+W pada keyboard masukan kata Prolink lalu tekan enter, maka kursor akan tertuju ke script Prolink tersebut,terlihat kata ATTRS dibawahnya seperti berikut :

ATTRS ……

Edit file ATTRS tersebut dengan menambah tanda commnet ‘#’ didepannya seperti berikut :

#ATTRS …

Lalu simpan dengan perintah Ctrl+O pada keyboard, kemudian exit dengan Ctrl+X.

Selanjutnya cabut modem kemudian pasang kembali dan lakukan perintah eject pada storage sbb:

$ sudo eject /dev/sr1

Lalu ketik perintah berikut :

$ lsusb

Maka akan muncul script berikut :

Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 003 Device 002: ID 0a12:0001 Cambridge Silicon Radio, Ltd Bluetooth Dongle (HCI mode)
Bus 005 Device 009: ID
19f5:9909

Terlihat bahwa ID modem kita 19f5:9909

Lalu ketik perintah lagi sebagai berikut

$ sudo modprobe usbserial vendor=0x19f5 product=0×9909

Kemudian cabut modem dari port usb, kemudian ketik perintah :

$ sudo rmmod usb-storage

Untuk mengatur supaya modul driver usb modem langsung terbaca pada saat booting, ketik perintah berikut :

$ sudo gedit /etc/modules

lalu masukan baris seperti di bawah ini

usbserial vendor=0x19f5 product=0x9909

Supaya usb cdrom yang teraktifkan langsung di eject, ketik perintah

$ sudo gedit /lib/udev/rules.d/61-mobile-action.rules

masukan baris entri baru di akhir file tersebut.

ACTION==”add”, ENV{ID_CDROM}==”1″, ENV{ID_VENDOR_ID}==”05c6″, ENV{ID_MODEL_ID}==”1000″, RUN+=”/usr/bin/eject %k”

Simpan semua perubahan dengan menekan Ctrl+O pada terminal Ubuntu kita.

Langkah terakhir lakukan konfigurasi koneksi bias dengan menu bawaaan Ubuntu atau dengan wvdial.

Restart Ubuntu anda.

Lakukan koneksi dengan modem Venus Fast 2 di Ubuntu anda. Selamat mencoba

Ikuti

Get every new post delivered to your Inbox.