Beranda > Internet, Koneksi Jaringan, Mikrotik, OS Linux > Limit Torrent di Mikrotik

Limit Torrent di Mikrotik

Berawal dari dari adanya client hotspot yang hobby download film menggunakan torrent. Repotnya walau bandwidth sudah dibatasi di user hotspot tapi dengan torrent bisa tembus hingga bandwidth di DRNet bisa terkuras habis oleh satu client. Rugi dong client yang laen pada teriak… akhirnya begadang semaleman muter otak cari konsep limit bandwidth yang bisa membatasi torrent. Akhirnya ketemu deh caranya.. dan tutorial berikut gabungan dari artikel blokir torrent dan membatasi bandwith iix dan intl serta queue tree membatasi bandwith client sama rata. Ok simak saja langsung scripnya, semoga bermanfaat.

A.    Membuat Layer 7 Protocol untuk menangkap Torrent
/ip firewall layer7-protocol

add name=bittorrent regexp=”^(\13bittorrent protocol|azver1\$|get /scrape\\\?info_hash=)|d1:ad2:id20:|8’7P\\)[RP]”

add name=torrent-wws regexp=”^.*(get|GET).+(torrent|info_hash|thepiratebay|isohunt|entertane|demonoid|btjunkie|mininova|flixflux|vertor|h33t|zoozle|bitnova|bitsoup|meganova|fulldls|btbot|fenopy|gpirate|commonbits).*\$”

add name=torrent-www regexp=\”^.+(torrent|thepiratebay|isohunt|entertane|demonoid|btjunkie|mininova|flixflux|vertor|h33t|zoozle|bitnova|bitsoup|meganova|fulldls|btbot|fenopy|gpirate|commonbits).*\$”

B.     Membuat Mangle

/ip firewall mangle

add action=mark-connection chain=forward layer7-protocol=bittorent new-connection-mark=bittorent-limit passthrough=yes comment=”bittorent”

add action=mark-packet chain=forward connection-mark=bittorent-limit new-packet-mark=packet-bittorent passthrough=no

add action=mark-connection chain=forward layer7-protocol=torrent-wws new-connection-mark=wws-limit passthrough=yes comment=”torrent wws”

add action=mark-packet chain=forward connection-mark=wws-limit new-packet-mark=packet-wws passthrough=no

add action=mark-connection chain=forward layer7-protocol=torrent-www new-connection-mark=www-limit passthrough=yes comment=”torrent www”

add action=mark-packet chain=forward connection-mark=www-limit new-packet-mark=packet-www passthrough=no

add action=mark-connection chain=forward p2p=all-p2p new-connection-mark=allp2p-limit passthrough=yes comment=”torrent allp2p”

add action=mark-packet chain=forward connection-mark= allp2p-limit new-packet-mark=packet-allp2p passthrough=no

add action=mark-connection chain=forward protocol=tcp src-port= 58561,58045,14948,58008,58816,59097 new-connection-mark=port-limit passthrough=yes comment=”torrent port”

add action=mark-packet chain=forward connection-mark= port-limit new-packet-mark=packet-port passthrough=no

C.    Membuat Queue Type

/queue type
add kind=pcq name=torrent pcq-classifier=dst-address pcq-limit=50 pcq-rate=128k pcq-total-limit=2000

D.    Membuat Queue Tree

/queue tree
add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=0
max-limit=256kname=bittorrent packet-mark=packet-bittorent parent=global-out priority=8 queue=torrent comment=”limit torrent”

add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=0
max-limit=256kname=wws packet-mark=packet-wws parent=global-out priority=8 queue=torrent

add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=0
max-limit=256kname=www packet-mark=packet-www parent=global-out priority=8 queue=torrent

add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=0
max-limit=256kname=port packet-mark=packet-port parent=global-out priority=8 queue=torrent

add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=0
max-limit=256kname=allp2p packet-mark=packet-allp2p parent=global-out priority=8 queue=torrent

begitu saja sudah cukup, client yang pake torrent akhirnya bisa dibatasi dengan bandwidth di queue tree yang kita tentukan. Keep ngoprek.. ^_^

  1. boypeaceboypeace
    Desember 19, 2012 pukul 8:59 am

    ini di mikrotik Versi Berapa gan??

  2. Maret 20, 2013 pukul 9:28 am

    kalau untuk mikrotik v 7 bisa tidak ?

    • Agustus 28, 2013 pukul 2:32 pm

      saya coba di mikrotik v5.2 berjalan dengan baik, dicoba aja untuk v.7 nya ..

  3. Agus
    September 26, 2013 pukul 6:14 am

    Ijin share ya bang mimin

  1. No trackbacks yet.

Tinggalkan Balasan

Isikan data di bawah atau klik salah satu ikon untuk log in:

Logo WordPress.com

You are commenting using your WordPress.com account. Logout / Ubah )

Gambar Twitter

You are commenting using your Twitter account. Logout / Ubah )

Foto Facebook

You are commenting using your Facebook account. Logout / Ubah )

Foto Google+

You are commenting using your Google+ account. Logout / Ubah )

Connecting to %s

%d blogger menyukai ini: